<!doctype html > <!--[if IE 8]><html class=ie8 lang=en> <![endif]--> <!--[if IE 9]><html class=ie9 lang=en> <![endif]--> <!--[if gt IE 8]><!--><html lang=en-US> <!--<![endif]--><head><meta charset=UTF-8>
<script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=function(){var u=[],i="/porpoiseant/army.gif";function t(e,i,t,_,d,o,n){if(__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var r=parseInt(__ez.dot.getTargeting(e,"ap")),a=__ez.dot.getSlotIID(e),s=__ez.dot.getAdUnit(e),p=parseInt(__ez.dot.getTargeting(e,"compid")),z=0,f=0,g=function(e){if("undefined"==typeof _ezim_d)return!1;var i=__ez.dot.getAdUnitPath(e).split("/").pop();if("object"==typeof _ezim_d&&_ezim_d.hasOwnProperty(i))return _ezim_d[i];for(var t in _ezim_d)if(t.split("/").pop()===i)return _ezim_d[t];return!1}(e);"object"==typeof g&&(void 0!==g.creative_id&&(f=g.creative_id),void 0!==g.line_item_id&&(z=g.line_item_id)),__ez.dot.isDefined(a,s)&&__ez.dot.isValid(i)&&u.push({type:"impression",impression_id:a,domain_id:__ez.dot.getDID(),unit:s,t_epoch:__ez.dot.getEpoch(0),revenue:t,est_revenue:_,ad_position:r,ad_size:"",bid_floor_filled:d,bid_floor_prev:o,stat_source_id:n,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:p,line_item_id:z,creative_id:f,data:__ez.dot.dataToStr(i)})}}function _(){if(void 0===document.visibilityState||"prerender"!==document.visibilityState){if(__ez.dot.isDefined(u)&&0<u.length){var e=__ez.dot.getURL(i)+"?orig="+(!0===__ez.template.isOrig?1:0)+"&sts="+btoa(JSON.stringify(u));void 0!==window.isAmp&&isAmp&&void 0!==window._ezaq&&_ezaq.hasOwnProperty("domain_id")&&(e+="&visit_uuid="+_ezaq.visit_uuid),(new Image).src=e}u=[]}}return{Add:t,AddAndFire:function(e,i){t(e,i,0,0,0,0,0),_()},AddById:function(e,i){var t=e.split("/");if(__ez.dot.isDefined(e)&&3===t.length&&__ez.dot.isValid(i)){var _=t[0],d=t[2];u.push({type:"impression",impression_id:d,domain_id:__ez.dot.getDID(),unit:_,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(i)})}},Fire:_,GetPixels:function(){return u}}}();var EzoicPixel=function(){this.pixels=[],this.pixelUrl="/ezoic/e.gif",("undefined"!=typeof ezJsu&&!0===ezJsu||"undefined"!=typeof _ez_sa&&!0===_ez_sa||void 0!==window.isAmp&&!0===isAmp||"undefined"!=typeof ezWp&&!0===ezWp)&&(this.pixelUrl="//g.ezoic.net"+this.pixelUrl),this.tEpoch=0,"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("t_epoch")&&(this.tEpoch=_ezaq.t_epoch)},EzoicPixelData=function(e,i){this.name=e,this.val=i};EzoicPixel.prototype={constructor:EzoicPixel,AddAndFireImpPixel:function(e,i){this.AddImpPixel(e,i,0,0,0,0,0),this.FirePixels()},AddAndFirePVPixel:function(e,i){this.AddPVPixel(e,i),this.FirePixels()},AddImpPixel:function(e,i,t,n,o,a,d){if(0!=__ez.dot.isDefined(e)&&0!=__ez.dot.isAnyDefined(e.getSlotElementId,e.ElementId)){var s=parseInt(__ez.dot.getTargeting(e,"ap")),r=__ez.dot.getSizes(e)[0],_=r.l.toString()+"x"+r.j.toString(),p="0",l="XX";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(p=_ezaq.domain_id.toString()),"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("country")&&(l=_ezaq.country);var h=__ez.dot.getSlotIID(e),c=__ez.dot.getSlotElementId(e);__ez.dot.isDefined(h,c)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:h,domain_id:p,unit:c,t_epoch:this.tEpoch,revenue:t,est_revenue:n,ad_position:s,ad_size:_,bid_floor_filled:o,bid_floor_prev:a,stat_source_id:d,country_code:l,data:i}))}},AddImpPixelById:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString());var n=e.split("/");if(__ez.dot.isDefined(e)&&3===n.length&&this.validateData(i)){var o=n[0],a=n[2];i=this.convertDataToStr(i),this.pixels.push({type:"impression",impression_id:a,domain_id:t,unit:o,t_epoch:this.tEpoch,data:i})}},AddPVPixel:function(e,i){var t="0";"undefined"!=typeof _ezaq&&_ezaq.hasOwnProperty("domain_id")&&(t=_ezaq.domain_id.toString()),__ez.dot.isDefined(e)&&this.validateData(i)&&(i=this.convertDataToStr(i),this.pixels.push({type:"pageview",pageview_id:e,domain_id:t,t_epoch:this.tEpoch,data:i}))},FirePixels:function(){void 0!==document.visibilityState&&"prerender"===document.visibilityState||(__ez.dot.isDefined(this.pixels)&&0<this.pixels.length&&((new Image).src=this.pixelUrl+"?orig="+(!0===__ez.template.isOrig?1:0)+"&pixels="+encodeURIComponent(JSON.stringify(this.pixels))),this.pixels=[])},NewData:function(e,i){return new EzoicPixelData(e,i)},convertDataToStr:function(e){if(void 0===e)return[];try{for(var i in e)e[i].val=e[i].val+""}catch(e){}return e},validateData:function(e){for(var i=0;i<e.length;i++)if(e[i]instanceof EzoicPixelData==!1)return console.error("Invalid pixelData. ",e[i]),!1;return!0}};</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">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</script><script defer src=https://json-cdn.uscho.com/wp-content/cache/minify/0/fb316.default.include.2362c1.js></script> <title>Atlantic Hockey Picks: March 12-15 | College Hockey | USCHO.com</title><meta name=viewport content="width=device-width, initial-scale=1.0"><link rel=pingback href=https://www.uscho.com/xmlrpc.php><meta name=twitter:card content=summary><meta name=twitter:creator content=@USCHO><meta name=twitter:site content=@USCHO><meta property=og:title content="Atlantic Hockey Picks: March 12-15"><meta property=og:description content="Last Week:Dan: 5-3-0Chris: 7-1-0On The Season:Dan: 147-58-23 (.695)Chris: 140-65-23 (.664)This Week&#039;s Picks:Thursday, March 12 through Sunday, March 15Atlantic Hockey Tournament"><meta property=og:image content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><meta property=og:image content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><link rel=icon type=image/png href=//json-cdn.uscho.com/wp-content/uploads/2017/12/favicon-16x16.png><link rel=apple-touch-icon-precomposed sizes=76x76 href=https://json-cdn.uscho.com/wp-content/uploads/2019/10/apple-icon-76x76.png><link rel=apple-touch-icon-precomposed sizes=120x120 href=https://json-cdn.uscho.com/wp-content/uploads/2019/10/apple-icon-120x120.png><link rel=apple-touch-icon-precomposed sizes=152x152 href=https://json-cdn.uscho.com/wp-content/uploads/2019/10/apple-icon-152x152-1.png><link rel=apple-touch-icon-precomposed sizes=114x114 href=https://json-cdn.uscho.com/wp-content/uploads/2019/10/apple-icon-114x114.png><link rel=apple-touch-icon-precomposed sizes=144x144 href=https://json-cdn.uscho.com/wp-content/uploads/2019/10/apple-icon-144x144.png><meta name=description content="Last Week: Dan: 5-3-0 Chris: 7-1-0 On The Season: Dan: 147-58-23 (.695) Chris: 140-65-23 (.664) This Week&#039;s Picks: Thursday, March 12 through Sunday,"><meta name=robots content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"><link rel=canonical href=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/ ><meta property=og:locale content=en_US><meta property=og:type content=article><meta property=og:title content="Atlantic Hockey Picks: March 12-15 | College Hockey | USCHO.com"><meta property=og:description content="Last Week: Dan: 5-3-0 Chris: 7-1-0 On The Season: Dan: 147-58-23 (.695) Chris: 140-65-23 (.664) This Week&#039;s Picks: Thursday, March 12 through Sunday,"><meta property=og:url content=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/ ><meta property=og:site_name content="College Hockey | USCHO.com"><meta property=article:publisher content=https://www.facebook.com/OfficialUSCHO/ ><meta property=article:tag content="Atlantic Hockey"><meta property=article:tag content=frontd1m><meta property=article:section content=Picks><meta property=article:published_time content=2020-03-12T15:11:42+00:00><meta property=article:modified_time content=2020-03-12T16:23:03+00:00><meta property=og:updated_time content=2020-03-12T16:23:03+00:00><meta property=fb:app_id content=347537111988294><meta property=og:image content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><meta property=og:image:secure_url content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><meta property=og:image:width content=700><meta property=og:image:height content=466><meta name=twitter:card content=summary_large_image><meta name=twitter:description content="Last Week: Dan: 5-3-0 Chris: 7-1-0 On The Season: Dan: 147-58-23 (.695) Chris: 140-65-23 (.664) This Week&#039;s Picks: Thursday, March 12 through Sunday,"><meta name=twitter:title content="Atlantic Hockey Picks: March 12-15 | College Hockey | USCHO.com"><meta name=twitter:site content=@USCHO><meta name=twitter:image content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><meta name=twitter:creator content=@USCHO> <script type=application/ld+json class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.uscho.com/#website","url":"https://www.uscho.com/","name":"College Hockey | USCHO.com","inLanguage":"en-US","description":"Men&#039;s and Women&#039;s D-I and D-III College Hockey News, Features, Scores, Statistics, Fan Forum, Blogs","potentialAction":{"@type":"SearchAction","target":"https://www.uscho.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/#primaryimage","inLanguage":"en-US","url":"https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg","width":700,"height":466},{"@type":"WebPage","@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/#webpage","url":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/","name":"Atlantic Hockey Picks: March 12-15 | College Hockey | USCHO.com","isPartOf":{"@id":"https://www.uscho.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/#primaryimage"},"datePublished":"2020-03-12T15:11:42+00:00","dateModified":"2020-03-12T16:23:03+00:00","author":{"@id":"https://www.uscho.com/#/schema/person/c7e2de948b6b8fd4fb1d799b69f020fa"},"description":"Last Week: Dan: 5-3-0 Chris: 7-1-0 On The Season: Dan: 147-58-23 (.695) Chris: 140-65-23 (.664) This Week's Picks: Thursday, March 12 through Sunday,","breadcrumb":{"@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.uscho.com/","url":"https://www.uscho.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.uscho.com/latest/","url":"https://www.uscho.com/latest/","name":"Latest"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/","url":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/","name":"Atlantic Hockey Picks: March 12-15"}}]},{"@type":["Person"],"@id":"https://www.uscho.com/#/schema/person/c7e2de948b6b8fd4fb1d799b69f020fa","name":"Chris Lerch","image":{"@type":"ImageObject","@id":"https://www.uscho.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/94c0063537647be940992be3e0a0e99b?s=96&d=mm&r=g","caption":"Chris Lerch"},"description":"Atlantic Hockey Columnist","sameAs":[]}]}</script> <link rel=dns-prefetch href=//www.uscho.com><link rel=dns-prefetch href=//www.google.com><link rel=dns-prefetch href=//code.jquery.com><link rel=dns-prefetch href=//cdn.datatables.net><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="College Hockey | USCHO.com &raquo; Feed" href=https://www.uscho.com/feed/ ><link rel=alternate type=application/rss+xml title="College Hockey | USCHO.com &raquo; Comments Feed" href=https://www.uscho.com/comments/feed/ ><link rel=alternate type=application/rss+xml title="College Hockey | USCHO.com &raquo; Atlantic Hockey Picks: March 12-15 Comments Feed" href=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/feed/ ><link rel=stylesheet href=https://json-cdn.uscho.com/wp-content/cache/minify/0/fb316.default.include.8c0159.css media=all><meta property=fb:pages content=70650541332> <script>jsonURL='https://json-b.uscho.com/json/scoreboard/division-i-men/2019-2020/gameday/2020-03-12';todayDate='2020-03-12';</script>  <script type=text/javascript>var _qevents=_qevents||[];(function(){var elem=document.createElement('script');elem.src=(document.location.protocol=="https:"?"https://secure":"http://edge")+".quantserve.com/quant.js";elem.async=true;elem.type="text/javascript";var scpt=document.getElementsByTagName('script')[0];scpt.parentNode.insertBefore(elem,scpt);})();_qevents.push({qacct:"p-an_CHGCH-wfKr"});</script> <noscript><div style=display:none;> <img src=//pixel.quantserve.com/pixel/p-an_CHGCH-wfKr.gif border=0 height=1 width=1 alt=Quantcast></div> </noscript> <script data-cfasync=false type=text/javascript>(function(a,c,s,u){'Insticator'in a||(a.Insticator={ad:{loadAd:function(b){Insticator.ad.q.push(b)},q:[]},helper:{},embed:{},version:"4.0",q:[],load:function(t,o){Insticator.q.push({t:t,o:o})}});var b=c.createElement(s);b.src=u;b.async=!0;var d=c.getElementsByTagName(s)[0];d.parentNode.insertBefore(b,d)})(window,document,'script','//d3lcz8vpax4lo2.cloudfront.net/ads-code/dca06727-89e0-43d6-81ef-b6dbc6a5c4ec.js');</script> <link rel=stylesheet id=wgs2-css  href='https://json-cdn.uscho.com/wp-content/plugins/wp-google-search/wgs2.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=wp-block-library-css  href='https://json-cdn.uscho.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=dashicons-css  href='https://json-cdn.uscho.com/wp-includes/css/dashicons.min.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=aba_frontEndCSS-css  href='https://json-cdn.uscho.com/wp-content/plugins/ad-blocking-advisor/css/frontend.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=wpt-twitter-feed-css  href='https://json-cdn.uscho.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=contact-form-7-css  href='https://json-cdn.uscho.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type=text/css media=all><link rel=stylesheet id=tablepress-default-css  href='https://json-cdn.uscho.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.10' type=text/css media=all><style id=td-theme-inline-css type=text/css>@media (max-width: 767px){.td-header-desktop-wrap{display:none}}@media (min-width: 767px){.td-header-mobile-wrap{display:none}}</style><link rel=stylesheet id=td-theme-child-css  href='https://json-cdn.uscho.com/wp-content/themes/uscho-np/style.css?ver=9.8s' type=text/css media=all><link rel=stylesheet id=td-legacy-framework-front-style-css  href='https://json-cdn.uscho.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=5a862b9d7c39671de80dd6dee389818b' type=text/css media=all> <script>if(document.location.protocol!="https:"){document.location=document.URL.replace(/^http:/i,"https:");}</script><script type=text/javascript src='https://json-cdn.uscho.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/ad-blocking-advisor/js/ad-blocking-advisor.js?ver=5.3.2'></script> <script type=text/javascript src='https://code.jquery.com/ui/1.12.1/jquery-ui.min.js?ver=1.0'></script> <script type=text/javascript src='https://cdn.datatables.net/v/dt/dt-1.10.18/fc-3.2.5/r-2.2.2/datatables.min.js?ver=1.0'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/themes/uscho-np/js/uscho_scoreboard.js?ver=1.6a'></script> <link rel=https://api.w.org/ href=https://www.uscho.com/wp-json/ ><link rel=EditURI type=application/rsd+xml title=RSD href=https://www.uscho.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://json-cdn.uscho.com/wp-includes/wlwmanifest.xml><meta name=generator content="WordPress 5.3.2"><link rel=shortlink href='https://www.uscho.com/?p=105106'><link rel=alternate type=application/json+oembed href="https://www.uscho.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F"><link rel=alternate type=text/xml+oembed href="https://www.uscho.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F&#038;format=xml"><style>[class$="woocommerce-product-gallery__trigger"]{visibility:hidden}</style><meta name=google-site-verification content=h5xdVxaxDrzUxgQJK6G4C5Pi7VOVpKpIb6k791p0SNc><meta name=msvalidate.01 content=C7E1C206057C2913B8C3B43C159C2978><meta property=fb:pages content=70650541332>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-541124-2"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-541124-2');</script> <script async src=//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js></script> <script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-4191647241486880",enable_page_level_ads:true});</script> <!--[if lt IE 9]><script src=https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js></script><![endif]--> <script>window.tdwGlobal={"adminUrl":"https:\/\/www.uscho.com\/wp-admin\/","wpRestNonce":"f74861c057","wpRestUrl":"https:\/\/www.uscho.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};</script>  <script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}
(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}
if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}
if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}
if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}
var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}
if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}
if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}
if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}
if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}
if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var tdc_is_installed="yes";var td_ajax_url="https:\/\/www.uscho.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.8";var td_get_template_directory_uri="https:\/\/www.uscho.com\/wp-content\/plugins\/td-composer\/legacy\/common";var tds_snap_menu="snap";var tds_logo_on_sticky="show_header_logo";var tds_header_style="5";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#a71e40";var tds_smart_sidebar="";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdBlockNonce="d7f6a41ad6";var tdsDateFormat="l, F j, Y";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script> <style>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</style> <script type=application/ld+json>{"@context":"http://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebSite","@id":"https://www.uscho.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.uscho.com/picks/","name":"Picks"}},{"@type":"ListItem","position":3,"item":{"@type":"WebPage","@id":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/","name":"Atlantic Hockey Picks: March 12-15"}}]}</script> <style>.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .sfHover > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
.tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
.tds-button2 .tdm-btn-text,
.tds-button2 i,
.tds-button5:hover .tdm-btn-text,
.tds-button5:hover i,
.tds-button6 .tdm-btn-text,
.tds-button6 i,
.tdm_block_list .tdm-list-item i,
.tdm_block_pricing .tdm-pricing-feature i,
.tdm-social-item
i{color:#a71e40}.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-item > a,
.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > li > a:hover,
.tdm-menu-active-style5 .td-header-menu-wrap .sf-menu > .sfHover > a,
.tds-button1,
.tds-button6:after,
.tds-title2 .tdm-title-line:after,
.tds-title3 .tdm-title-line:after,
.tdm_block_pricing.tdm-pricing-featured:before,
.tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
.tds-progress-bar1 .tdm-progress-bar:after,
.tds-progress-bar2 .tdm-progress-bar:after,
.tds-social3 .tdm-social-item{background-color:#a71e40}.tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
.tdm-menu-active-style4 .tdm-header .sf-menu > .sfHover > a,
.tds-button2:before,
.tds-button6:before,
.tds-progress-bar3 .tdm-progress-bar:after{border-color:#a71e40}.tdm-btn-style1{background-color:#a71e40}.tdm-btn-style2:before{border-color:#a71e40}.tdm-btn-style2{color:#a71e40}.tdm-btn-style3{-webkit-box-shadow:0 2px 16px #a71e40;-moz-box-shadow:0 2px 16px #a71e40;box-shadow:0 2px 16px #a71e40}.tdm-btn-style3:hover{-webkit-box-shadow:0 4px 26px #a71e40;-moz-box-shadow:0 4px 26px #a71e40;box-shadow:0 4px 26px #a71e40}.tdm-header-style-1.td-header-wrap .td-header-top-menu-full,
.tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,
.tdm-header-style-2.td-header-wrap .td-header-top-menu-full,
.tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,
.tdm-header-style-3.td-header-wrap .td-header-top-menu-full,
.tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{background-color:#dedede}.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-item > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu > li > a:hover,
.tdm-menu-active-style3 .tdm-header.td-header-wrap .sf-menu>.sfHover>a{color:#a71e40}.tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-item > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style4 .tdm-header .sf-menu > li > a:hover,
.tdm-menu-active-style4 .tdm-header .sf-menu>.sfHover>a{border-color:#a71e40}.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-item > a,
.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-menu-ancestor > a,
.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > .current-category-ancestor > a,
.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu > li > a:hover,
.tdm-menu-active-style5 .tdm-header .td-header-menu-wrap .sf-menu>.sfHover>a{background-color:#a71e40}</style><link rel='canonical' href='https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/' />

<script data-ezscrex="false" data-cfasync="false" type="text/javascript">window.google_analytics_uacct = "UA-147545198-27";</script>
<script data-ezscrex="false" data-cfasync="false" type="text/javascript">
var _gaq = _gaq || [];
_gaq.push(['e._setAccount', 'UA-147545198-27']);
_gaq.push(['f._setAccount', 'UA-38339005-1']);
_gaq.push(['e._setDomainName', 'uscho.com']);
_gaq.push(['f._setDomainName', 'uscho.com']);
_gaq.push(['e._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['e._setCustomVar',2,'t','126',3]);
_gaq.push(['e._setCustomVar',3,'rid','0',2]);
_gaq.push(['e._setCustomVar',4,'bra','mod11-c',3]);
_gaq.push(['e._setAllowAnchor',true]);
_gaq.push(['e._setSiteSpeedSampleRate', 10]);
_gaq.push(['f._setCustomVar',1,'template','old_site_gc',3]);
_gaq.push(['f._setCustomVar',2,'domain','uscho.com',3]);
_gaq.push(['f._setSiteSpeedSampleRate', 20]);
_gaq.push(['e._trackPageview']);
_gaq.push(['f._trackPageview']);


(function() {
 var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
 ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
 var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})();
</script>
<script type="text/javascript">var ezouid = "1";</script><base href="https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 156210;
var ezdomain = 'uscho.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":156210,"engaged_time_visit":0,"ezcache_level":1,"forensiq_score":-1,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"23211465-8e2c-421b-55ee-f721fde281b4","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_time_orig":1047,"serverid":"34.224.70.8:2506","state":"VA","t_epoch":1584035449,"template_id":126,"time_on_site_visit":0,"url":"https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/","user_id":0,"word_count":1510,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script><script data-ezscrex='false' data-cfasync='false' type="text/javascript" src="/detroitchicago/rochester.js?cb=188-2&v=8" async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl() {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_156210=" + new Date().getTime() + "|23211465-8e2c-421b-55ee-f721fde281b4|false; " + expires, 3);
}
function attach_ezolpl() {
    if(window.attachEvent) {
        window.attachEvent('onload', create_ezolpl);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl();
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl;
        }
    }
}
attach_ezolpl();
</script></head><body data-rsssl=1 class="post-template-default single single-post postid-105106 single-format-standard atlantic-hockey-picks-march-12-15 global-block-template-1 single_template_5 td-full-layout" itemscope=itemscope itemtype=https://schema.org/WebPage><div class=td-scroll-up><i class=td-icon-menu-up></i></div><div class=td-menu-background></div><div id=td-mobile-nav><div class=td-mobile-container><div class=td-menu-socials-wrap><div class=td-menu-socials> <span class=td-social-icon-wrap> <a target=_blank href=https://www.facebook.com/OfficialUSCHO/ title=Facebook> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class=td-social-icon-wrap> <a target=_blank href=https://twitter.com/uscho title=Twitter> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class=td-mobile-close> <a href=#><i class=td-icon-close-mobile></i></a></div></div><div class=td-mobile-content><div class=menu-main-menu-container><ul id=menu-main-menu class=td-mobile-main-menu><li id=menu-item-94120 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-first menu-item-94120"><a href=https://www.uscho.com/ >D-I Men<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-71595 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71595"><a href=/conference/atlantic-hockey/ >Atlantic Hockey</a></li><li id=menu-item-71680 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71680"><a href=/conference/big-ten/ >Big Ten</a></li><li id=menu-item-71765 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71765"><a href=/conference/ecac/ >ECAC Hockey</a></li><li id=menu-item-71811 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71811"><a href=/conference/d-i-independent/ >Independents</a></li><li id=menu-item-71778 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71778"><a href=/conference/hockey-east/ >Hockey East</a></li><li id=menu-item-71791 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71791"><a href=/conference/nchc/ >NCHC</a></li><li id=menu-item-71800 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71800"><a href=/conference/wcha/ >WCHA</a></li></ul></li><li id=menu-item-71813 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-71813"><a href=https://www.uscho.com/d1women/ >D-I Women<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-71814 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71814"><a href=/conference/cha-women/ >CHA</a></li><li id=menu-item-71821 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71821"><a href=/conference/ecac-women/ >ECAC Hockey</a></li><li id=menu-item-71834 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71834"><a href=/conference/hockey-east-women/ >Hockey East</a></li><li id=menu-item-71853 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71853"><a href=/conference/newha-women/ >NEWHA</a></li><li id=menu-item-71844 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71844"><a href=/conference/wcha-women/ >WCHA</a></li></ul></li><li id=menu-item-71855 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-71855"><a href=https://www.uscho.com/d3men/ >D-II/III Men<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-99648 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99648"><a href=/conference/ccc/ >CCC</a></li><li id=menu-item-71876 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71876"><a href=/conference/mascac/ >MASCAC</a></li><li id=menu-item-71884 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71884"><a href=/conference/miac/ >MIAC</a></li><li id=menu-item-71894 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71894"><a href=/conference/ncha/ >NCHA</a></li><li id=menu-item-71906 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71906"><a href=/conference/nehc/ >NEHC</a></li><li id=menu-item-71917 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71917"><a href=/conference/nescac/ >NESCAC</a></li><li id=menu-item-71928 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71928"><a href=/conference/northeast-10/ >Northeast-10</a></li><li id=menu-item-71933 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71933"><a href=/conference/sunyac/ >SUNYAC</a></li><li id=menu-item-71867 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71867"><a href=/conference/uchc/ >UCHC</a></li><li id=menu-item-71943 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71943"><a href=/conference/wiac/ >WIAC</a></li><li id=menu-item-71949 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71949"><a href=/conference/d-iii-independent/ >Independents</a></li></ul></li><li id=menu-item-71952 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-71952"><a href=https://www.uscho.com/d3women/ >D-III Women<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-71953 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71953"><a href=/conference/colonial-hockey-women/ >Colonial Hockey</a></li><li id=menu-item-71973 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71973"><a href=/conference/miac-women/ >MIAC</a></li><li id=menu-item-71984 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71984"><a href=/conference/ncha-women/ >NCHA</a></li><li id=menu-item-71992 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71992"><a href=/conference/nehc-women/ >NEHC</a></li><li id=menu-item-72007 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72007"><a href=/conference/nescac-women/ >NESCAC</a></li><li id=menu-item-71962 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-71962"><a href=/conference/newhl-women/ >NEWHL</a></li><li id=menu-item-72022 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72022"><a href=/conference/uchc-women/ >UCHC</a></li><li id=menu-item-72017 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72017"><a href=/conference/wiac-women/ >WIAC</a></li><li id=menu-item-88147 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-88147"><a href=/conference/d-iii-independent-women/ >Independents</a></li></ul></li><li id=menu-item-80009 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80009"><a href=/gameday/ >Scores<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-72028 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72028"><a href=/gameday/division-i-men/ >Division I hockey men</a></li><li id=menu-item-72029 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72029"><a href=/gameday/division-i-women/ >Division I hockey women</a></li><li id=menu-item-72030 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72030"><a href=/gameday/division-iii-men/ >Division III hockey men</a></li><li id=menu-item-72031 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72031"><a href=/gameday/division-iii-women/ >Division III hockey women</a></li></ul></li><li id=menu-item-72032 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72032"><a href=https://www.uscho.com/rankings/ >Rankings<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-72033 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72033"><a href=/rankings/d-i-mens-poll/ >Division I Men&#8217;s Hockey Poll</a></li><li id=menu-item-72034 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72034"><a href=/rankings/d-i-womens-poll/ >Division I Women&#8217;s Hockey Poll</a></li><li id=menu-item-72035 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72035"><a href=/rankings/d-iii-mens-poll/ >Division III Men&#8217;s Hockey Poll</a></li><li id=menu-item-72036 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72036"><a href=/rankings/d-iii-womens-poll/ >Division III Women&#8217;s Hockey Poll</a></li><li id=menu-item-72037 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72037"><a href=/rankings/pairwise-rankings/d-i-men/ >D-I Men&#8217;s Hockey PairWise</a></li><li id=menu-item-72038 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72038"><a href=/rankings/rpi/d-i-men/ >D-I Men&#8217;s Hockey RPI</a></li><li id=menu-item-72039 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72039"><a href=/rankings/pairwise-rankings/d-i-women/ >D-I Women&#8217;s Hockey PairWise</a></li><li id=menu-item-72040 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72040"><a href=/rankings/rpi/d-i-women/ >D-I Women&#8217;s Hockey RPI</a></li><li id=menu-item-90398 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90398"><a href=/rankings/pairwise-rankings/d-iii-men/ >D-III Men&#8217;s Hockey PairWise</a></li><li id=menu-item-90399 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90399"><a href=/rankings/rpi/d-iii-men/ >D-III Men&#8217;s Hockey RPI</a></li><li id=menu-item-90400 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90400"><a href=/rankings/pairwise-rankings/d-iii-women/ >D-III Women&#8217;s Hockey PairWise</a></li><li id=menu-item-90401 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-90401"><a href=/rankings/rpi/d-iii-women/ >D-III Women&#8217;s Hockey RPI</a></li></ul></li><li id=menu-item-72047 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72047"><a href=https://www.uscho.com/stats/ >Stats<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-72048 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72048"><a href=/stats/overall/division-i-men/ >Division I men&#8217;s hockey stats<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-93943 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93943"><a href=/stats/overall/division-i-men/ >Division I men&#8217;s overall stats</a></li><li id=menu-item-82957 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82957"><a href=/stats/attendance/division-i-men/ >Attendance</a></li><li id=menu-item-82958 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82958"><a href=/stats/interconference/division-i-men/ >Inter-conference college hockey records</a></li><li id=menu-item-84890 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84890"><a href=/stats/longest-games/ >Longest college hockey games</a></li></ul></li><li id=menu-item-72049 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72049"><a href=/stats/overall/division-i-women/ >Division I women&#8217;s hockey stats<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-93945 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93945"><a href=/stats/overall/division-i-women/ >Division I women&#8217;s overall stats</a></li><li id=menu-item-82959 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82959"><a href=/stats/attendance/division-i-women/ >Attendance</a></li><li id=menu-item-82960 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82960"><a href=/stats/interconference/division-i-women/ >Inter-conference records</a></li></ul></li><li id=menu-item-72050 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72050"><a href=/stats/overall/division-iii-men/ >Division III men&#8217;s hockey stats<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-93944 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93944"><a href=/stats/overall/division-iii-men/ >Division III men&#8217;s overall stats</a></li><li id=menu-item-82961 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82961"><a href=/stats/attendance/division-iii-men/ >Attendance</a></li><li id=menu-item-82962 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82962"><a href=/stats/interconference/division-iii-men/ >Inter-conference records</a></li></ul></li><li id=menu-item-72051 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72051"><a href=/stats/overall/division-iii-women/ >Division III women&#8217;s hockey stats<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-93946 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-93946"><a href=/stats/overall/division-iii-women/ >Division III women&#8217;s overall stats</a></li><li id=menu-item-82963 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82963"><a href=/stats/attendance/division-iii-women/ >Attendance</a></li><li id=menu-item-82964 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-82964"><a href=/stats/interconference/division-iii-women/ >Inter-conference records</a></li></ul></li><li id=menu-item-72052 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72052"><a href=/stats/player/ >Player search</a></li><li id=menu-item-72053 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72053"><a href=/stats/coach/ >Coach search</a></li><li id=menu-item-86457 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-86457"><a href=/faq/awards/ >Awards</a></li></ul></li><li id=menu-item-72054 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72054"><a href=https://www.uscho.com/standings/ >Standings<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-72055 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72055"><a href=/standings/division-i-men/ >Division I men&#8217;s hockey standings</a></li><li id=menu-item-72056 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72056"><a href=/standings/division-i-women/ >Division I women&#8217;s hockey standings</a></li><li id=menu-item-72057 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72057"><a href=/standings/division-iii-men/ >Division III men&#8217;s standings</a></li><li id=menu-item-72058 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72058"><a href=/standings/division-iii-women/ >Division III women&#8217;s hockey standings</a></li></ul></li><li id=menu-item-84195 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-84195"><a href=/ncaa/ >NCAA<i class="td-icon-menu-right td-element-after"></i></a><ul class=sub-menu><li id=menu-item-84196 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84196"><a href=/ncaa/mens-division-i-ncaa-tournament/ >Division I men&#8217;s hockey tournament</a></li><li id=menu-item-84197 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84197"><a href=/ncaa/womens-division-i-ncaa-tournament/ >Division I women&#8217;s hockey tournament</a></li><li id=menu-item-84198 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84198"><a href=/ncaa/mens-division-iii-ncaa-tournament/ >Division III men&#8217;s hockey tournament</a></li><li id=menu-item-84199 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-84199"><a href=/ncaa/womens-division-iii-ncaa-tournament/ >Division III women&#8217;s hockey tournament</a></li></ul></li><li id=menu-item-93783 class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-93783"><a href=https://www.uscho.com/news/ >News</a></li><li id=menu-item-94118 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-94118"><a href=https://www.uscho.com/teams/ >Teams</a></li></ul></div></div></div><div id=login-form-mobile class=td-register-section><div id=td-login-mob class="td-login-animation td-login-hide-mob"><div class=td-login-close> <a href=# class=td-back-button><i class=td-icon-read-down></i></a><div class=td-login-title>Sign in</div><div class=td-mobile-close> <a href=#><i class=td-icon-close-mobile></i></a></div></div><div class=td-login-form-wrap><div class=td-login-panel-title><span>Welcome!</span>Log into your account</div><div class=td_display_err></div><div class=td-login-inputs><input class=td-login-input type=text name=login_email id=login_email-mob value required><label>your username</label></div><div class=td-login-inputs><input class=td-login-input type=password name=login_pass id=login_pass-mob value required><label>your password</label></div> <input type=button name=login_button id=login_button-mob class=td-login-button value="LOG IN"><div class=td-login-info-text> <a href=# id=forgot-pass-link-mob>Forgot your password?</a></div><div class=td-login-register-link></div></div></div><div id=td-forgot-pass-mob class="td-login-animation td-login-hide-mob"><div class=td-forgot-pass-close> <a href=# class=td-back-button><i class=td-icon-read-down></i></a><div class=td-login-title>Password recovery</div></div><div class=td-login-form-wrap><div class=td-login-panel-title>Recover your password</div><div class=td_display_err></div><div class=td-login-inputs><input class=td-login-input type=text name=forgot_email id=forgot_email-mob value required><label>your email</label></div> <input type=button name=forgot_button id=forgot_button-mob class=td-login-button value="Send My Pass"></div></div></div></div><div class=td-search-background></div><div class=td-search-wrap-mob><div class=td-drop-down-search aria-labelledby=td-header-search-button><form method=get class=td-search-form action=https://www.uscho.com/ ><div class=td-search-close> <a href=#><i class=td-icon-close-mobile></i></a></div><div role=search class=td-search-input> <span>Search</span> <input id=td-header-search-mob type=text value name=s autocomplete=off></div></form><div id=td-aj-search-mob></div></div></div><div id=td-outer-wrap class=td-theme-wrap><div class="tdc-header-wrap "><div class="td-header-wrap td-header-style-5 "><div class="td-header-top-menu-full td-container-wrap td_stretch_container td_stretch_content_1400"><div class="td-container td-header-row td-header-top-menu"><div class=top-bar-style-1><div class=td-header-sp-top-menu><div class=td_data_time><div style=visibility:hidden;>Thursday, March 12, 2020</div></div><div class=menu-top-container><ul id=menu-top-header class=top-header-menu><li id=menu-item-72085 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-72085"><a href=https://fanforum.uscho.com/ >Fan Forum</a></li><li id=menu-item-72084 class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-72084"><a href=https://www.uscho.com/tv/ >TV</a></li><li id=menu-item-72086 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72086"><a href=/podcasts/ >Podcasts</a></li><li id=menu-item-72087 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72087"><a href=/about/ >About USCHO</a></li><li id=menu-item-72142 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72142"><a href=https://shop.uscho.com/ >shop.USCHO.com</a></li><li id=menu-item-80020 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80020"><a href=/ncaa/report-a-site-problem/ >Report a site problem</a></li></ul></div></div><div class=td-header-sp-top-widget><div class=td-search-btns-wrap> <a id=td-header-search-button href=# role=button class="dropdown-toggle " data-toggle=dropdown><i class=td-icon-search></i></a></div><div class=td-drop-down-search aria-labelledby=td-header-search-button><form method=get class=td-search-form action=https://www.uscho.com/ ><div role=search class=td-head-form-search-wrap> <input id=td-header-search type=text value name=s autocomplete=off><input class="wpb_button wpb_btn-inverse btn" type=submit id=td-header-search-top value=Search></div></form><div id=td-aj-search></div></div></div></div><div id=login-form class="white-popup-block mfp-hide mfp-with-anim"><div class=td-login-wrap> <a href=# class=td-back-button><i class=td-icon-modal-back></i></a><div id=td-login-div class="td-login-form-div td-display-block"><div class=td-login-panel-title>Sign in</div><div class=td-login-panel-descr>Welcome! Log into your account</div><div class=td_display_err></div><div class=td-login-inputs><input class=td-login-input type=text name=login_email id=login_email value required><label>your username</label></div><div class=td-login-inputs><input class=td-login-input type=password name=login_pass id=login_pass value required><label>your password</label></div> <input type=button name=login_button id=login_button class="wpb_button btn td-login-button" value=Login><div class=td-login-info-text><a href=# id=forgot-pass-link>Forgot your password? Get help</a></div></div><div id=td-forgot-pass-div class="td-login-form-div td-display-none"><div class=td-login-panel-title>Password recovery</div><div class=td-login-panel-descr>Recover your password</div><div class=td_display_err></div><div class=td-login-inputs><input class=td-login-input type=text name=forgot_email id=forgot_email value required><label>your email</label></div> <input type=button name=forgot_button id=forgot_button class="wpb_button btn td-login-button" value="Send My Password"><div class=td-login-info-text>A password will be e-mailed to you.</div></div></div></div></div></div><div class="td-header-menu-wrap-full td-container-wrap td_stretch_container td_stretch_content_1400"><div class="td-header-menu-wrap td-header-menu-no-search"><div class="td-container td-header-row td-header-main-menu black-menu"><div id=td-header-menu role=navigation><div id=td-top-mobile-toggle><a href=#><i class="td-icon-font td-icon-mobile"></i></a></div><div class="td-main-menu-logo td-logo-in-menu"> <a class=td-main-logo href=https://www.uscho.com/ > <img src=https://json-cdn.uscho.com/wp-content/uploads/2019/07/uscho150-150x22.png alt> <span class=td-visual-hidden>College Hockey | USCHO.com</span> </a></div><div class=menu-main-menu-container><ul id=menu-main-menu-1 class=sf-menu><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-first td-menu-item td-normal-menu menu-item-94120"><a href=https://www.uscho.com/ >D-I Men</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71595"><a href=/conference/atlantic-hockey/ >Atlantic Hockey</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71680"><a href=/conference/big-ten/ >Big Ten</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71765"><a href=/conference/ecac/ >ECAC Hockey</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71811"><a href=/conference/d-i-independent/ >Independents</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71778"><a href=/conference/hockey-east/ >Hockey East</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71791"><a href=/conference/nchc/ >NCHC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71800"><a href=/conference/wcha/ >WCHA</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-71813"><a href=https://www.uscho.com/d1women/ >D-I Women</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71814"><a href=/conference/cha-women/ >CHA</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71821"><a href=/conference/ecac-women/ >ECAC Hockey</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71834"><a href=/conference/hockey-east-women/ >Hockey East</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71853"><a href=/conference/newha-women/ >NEWHA</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71844"><a href=/conference/wcha-women/ >WCHA</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-71855"><a href=https://www.uscho.com/d3men/ >D-II/III Men</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-99648"><a href=/conference/ccc/ >CCC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71876"><a href=/conference/mascac/ >MASCAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71884"><a href=/conference/miac/ >MIAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71894"><a href=/conference/ncha/ >NCHA</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71906"><a href=/conference/nehc/ >NEHC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71917"><a href=/conference/nescac/ >NESCAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71928"><a href=/conference/northeast-10/ >Northeast-10</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71933"><a href=/conference/sunyac/ >SUNYAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71867"><a href=/conference/uchc/ >UCHC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71943"><a href=/conference/wiac/ >WIAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71949"><a href=/conference/d-iii-independent/ >Independents</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-71952"><a href=https://www.uscho.com/d3women/ >D-III Women</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71953"><a href=/conference/colonial-hockey-women/ >Colonial Hockey</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71973"><a href=/conference/miac-women/ >MIAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71984"><a href=/conference/ncha-women/ >NCHA</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71992"><a href=/conference/nehc-women/ >NEHC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72007"><a href=/conference/nescac-women/ >NESCAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-71962"><a href=/conference/newhl-women/ >NEWHL</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72022"><a href=/conference/uchc-women/ >UCHC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72017"><a href=/conference/wiac-women/ >WIAC</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-88147"><a href=/conference/d-iii-independent-women/ >Independents</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-80009"><a href=/gameday/ >Scores</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72028"><a href=/gameday/division-i-men/ >Division I hockey men</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72029"><a href=/gameday/division-i-women/ >Division I hockey women</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72030"><a href=/gameday/division-iii-men/ >Division III hockey men</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72031"><a href=/gameday/division-iii-women/ >Division III hockey women</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-72032"><a href=https://www.uscho.com/rankings/ >Rankings</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72033"><a href=/rankings/d-i-mens-poll/ >Division I Men&#8217;s Hockey Poll</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72034"><a href=/rankings/d-i-womens-poll/ >Division I Women&#8217;s Hockey Poll</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72035"><a href=/rankings/d-iii-mens-poll/ >Division III Men&#8217;s Hockey Poll</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72036"><a href=/rankings/d-iii-womens-poll/ >Division III Women&#8217;s Hockey Poll</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72037"><a href=/rankings/pairwise-rankings/d-i-men/ >D-I Men&#8217;s Hockey PairWise</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72038"><a href=/rankings/rpi/d-i-men/ >D-I Men&#8217;s Hockey RPI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72039"><a href=/rankings/pairwise-rankings/d-i-women/ >D-I Women&#8217;s Hockey PairWise</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72040"><a href=/rankings/rpi/d-i-women/ >D-I Women&#8217;s Hockey RPI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-90398"><a href=/rankings/pairwise-rankings/d-iii-men/ >D-III Men&#8217;s Hockey PairWise</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-90399"><a href=/rankings/rpi/d-iii-men/ >D-III Men&#8217;s Hockey RPI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-90400"><a href=/rankings/pairwise-rankings/d-iii-women/ >D-III Women&#8217;s Hockey PairWise</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-90401"><a href=/rankings/rpi/d-iii-women/ >D-III Women&#8217;s Hockey RPI</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-72047"><a href=https://www.uscho.com/stats/ >Stats</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-72048"><a href=/stats/overall/division-i-men/ >Division I men&#8217;s hockey stats</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93943"><a href=/stats/overall/division-i-men/ >Division I men&#8217;s overall stats</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82957"><a href=/stats/attendance/division-i-men/ >Attendance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82958"><a href=/stats/interconference/division-i-men/ >Inter-conference college hockey records</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-84890"><a href=/stats/longest-games/ >Longest college hockey games</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-72049"><a href=/stats/overall/division-i-women/ >Division I women&#8217;s hockey stats</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93945"><a href=/stats/overall/division-i-women/ >Division I women&#8217;s overall stats</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82959"><a href=/stats/attendance/division-i-women/ >Attendance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82960"><a href=/stats/interconference/division-i-women/ >Inter-conference records</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-72050"><a href=/stats/overall/division-iii-men/ >Division III men&#8217;s hockey stats</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93944"><a href=/stats/overall/division-iii-men/ >Division III men&#8217;s overall stats</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82961"><a href=/stats/attendance/division-iii-men/ >Attendance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82962"><a href=/stats/interconference/division-iii-men/ >Inter-conference records</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-72051"><a href=/stats/overall/division-iii-women/ >Division III women&#8217;s hockey stats</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-93946"><a href=/stats/overall/division-iii-women/ >Division III women&#8217;s overall stats</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82963"><a href=/stats/attendance/division-iii-women/ >Attendance</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-82964"><a href=/stats/interconference/division-iii-women/ >Inter-conference records</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72052"><a href=/stats/player/ >Player search</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72053"><a href=/stats/coach/ >Coach search</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-86457"><a href=/faq/awards/ >Awards</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children td-menu-item td-normal-menu menu-item-72054"><a href=https://www.uscho.com/standings/ >Standings</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72055"><a href=/standings/division-i-men/ >Division I men&#8217;s hockey standings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72056"><a href=/standings/division-i-women/ >Division I women&#8217;s hockey standings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72057"><a href=/standings/division-iii-men/ >Division III men&#8217;s standings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72058"><a href=/standings/division-iii-women/ >Division III women&#8217;s hockey standings</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children td-menu-item td-normal-menu menu-item-84195"><a href=/ncaa/ >NCAA</a><ul class=sub-menu><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-84196"><a href=/ncaa/mens-division-i-ncaa-tournament/ >Division I men&#8217;s hockey tournament</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-84197"><a href=/ncaa/womens-division-i-ncaa-tournament/ >Division I women&#8217;s hockey tournament</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-84198"><a href=/ncaa/mens-division-iii-ncaa-tournament/ >Division III men&#8217;s hockey tournament</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-84199"><a href=/ncaa/womens-division-iii-ncaa-tournament/ >Division III women&#8217;s hockey tournament</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-mega-menu menu-item-93783"><a href=https://www.uscho.com/news/ >News</a><ul class=sub-menu><li id=menu-item-0 class=menu-item-0><div class=td-container-border><div class=td-mega-grid><div class="td_block_wrap td_block_mega_menu td_uid_1_5e6a7679e2a1b_rand td-no-subcats td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid=td_uid_1_5e6a7679e2a1b ><script>var block_td_uid_1_5e6a7679e2a1b=new tdBlock();block_td_uid_1_5e6a7679e2a1b.id="td_uid_1_5e6a7679e2a1b";block_td_uid_1_5e6a7679e2a1b.atts='{"limit":"5","td_column_number":3,"ajax_pagination":"next_prev","category_id":"1","show_child_cat":30,"td_ajax_filter_type":"td_category_ids_filter","td_ajax_preloading":"","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","class":"td_uid_1_5e6a7679e2a1b_rand","tdc_css_class":"td_uid_1_5e6a7679e2a1b_rand","tdc_css_class_style":"td_uid_1_5e6a7679e2a1b_rand_style"}';block_td_uid_1_5e6a7679e2a1b.td_column_number="3";block_td_uid_1_5e6a7679e2a1b.block_type="td_block_mega_menu";block_td_uid_1_5e6a7679e2a1b.post_count="5";block_td_uid_1_5e6a7679e2a1b.found_posts="8004";block_td_uid_1_5e6a7679e2a1b.header_color="";block_td_uid_1_5e6a7679e2a1b.ajax_pagination_infinite_stop="";block_td_uid_1_5e6a7679e2a1b.max_num_pages="1601";tdBlocksArray.push(block_td_uid_1_5e6a7679e2a1b);</script><div id=td_uid_1_5e6a7679e2a1b class=td_block_inner><div class=td-mega-row><div class=td-mega-span><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/12/atlantic-hockey-announces-three-all-conference-teams-one-all-rookie-team/ rel=bookmark class=td-image-wrap title="Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season"><img width=218 height=150 class=entry-thumb src=https://www.photoshelter.com/img-get/I0000TvR9Vgxhq24/s/700/466/DSC-3704.jpg  srcset="https://www.photoshelter.com/img-get/I0000TvR9Vgxhq24/s/700/466/DSC-3704.jpg 218w, https://www.photoshelter.com/img-get/I0000TvR9Vgxhq24/s/700/466/DSC-3704.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team" title="Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/atlantic-hockey-announces-three-all-conference-teams-one-all-rookie-team/ rel=bookmark title="Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season">Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season</a></h3></div></div></div><div class=td-mega-span><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/12/mac-suspends-all-games-march-16-30-in-the-best-interest-of-campus-communities/ rel=bookmark class=td-image-wrap title="MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;"><img width=218 height=150 class=entry-thumb src=https://www.uscho.com/wp-content/uploads/2017/03/uscho_featured-1-218x150.png  srcset="https://www.uscho.com/wp-content/uploads/2017/03/uscho_featured-1-218x150.png 218w, https://www.uscho.com/wp-content/uploads/2017/03/uscho_featured-1-436x300.png 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt title="MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/mac-suspends-all-games-march-16-30-in-the-best-interest-of-campus-communities/ rel=bookmark title="MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;">MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;</a></h3></div></div></div><div class=td-mega-span><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/12/nchc-wcha-cancel-postseason-tournaments-due-to-coronavirus-precautions/ rel=bookmark class=td-image-wrap title="Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions"><img width=218 height=150 class=entry-thumb src=https://json-cdn.uscho.com/wp-content/uploads/2020/03/wcha-1024x345.png  srcset="https://json-cdn.uscho.com/wp-content/uploads/2020/03/wcha-1024x345.png 218w, https://json-cdn.uscho.com/wp-content/uploads/2020/03/wcha-1024x345.png 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="NCHC, WCHA cancel postseason tournaments due to coronavirus precautions" title="Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/nchc-wcha-cancel-postseason-tournaments-due-to-coronavirus-precautions/ rel=bookmark title="Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions">Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions</a></h3></div></div></div><div class=td-mega-span><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/11/coronavirus-precautions-force-ecac-hockey-to-re-seed-conference-tournament-after-harvard-yale-withdraw/ rel=bookmark class=td-image-wrap title="Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw"><img width=218 height=150 class=entry-thumb src=https://www.uscho.com/wp-content/uploads/2018/07/ecac.png  srcset="https://www.uscho.com/wp-content/uploads/2018/07/ecac.png 218w, https://www.uscho.com/wp-content/uploads/2018/07/ecac.png 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw" title="Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/coronavirus-precautions-force-ecac-hockey-to-re-seed-conference-tournament-after-harvard-yale-withdraw/ rel=bookmark title="Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw">Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw</a></h3></div></div></div><div class=td-mega-span><div class="td_module_mega_menu td-animation-stack td_mod_mega_menu"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/11/nchc-closes-all-quarterfinal-round-games-to-public-citing-coronavirus-concerns/ rel=bookmark class=td-image-wrap title="NCHC closes all quarterfinal-round games to public, citing coronavirus concerns"><img width=218 height=150 class=entry-thumb src=https://www.uscho.com/wp-content/uploads/2018/10/nchc-0307.gif  srcset="https://www.uscho.com/wp-content/uploads/2018/10/nchc-0307.gif 218w, https://www.uscho.com/wp-content/uploads/2018/10/nchc-0307.gif 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="NCHC closes all quarterfinal-round games to public, citing coronavirus concerns" title="NCHC closes all quarterfinal-round games to public, citing coronavirus concerns"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/nchc-closes-all-quarterfinal-round-games-to-public-citing-coronavirus-concerns/ rel=bookmark title="NCHC closes all quarterfinal-round games to public, citing coronavirus concerns">NCHC closes all quarterfinal-round games to public, citing coronavirus concerns</a></h3></div></div></div></div></div><div class=td-next-prev-wrap><a href=# class="td-ajax-prev-page ajax-page-disabled" id=prev-page-td_uid_1_5e6a7679e2a1b data-td_block_id=td_uid_1_5e6a7679e2a1b><i class="td-icon-font td-icon-menu-left"></i></a><a href=#  class=td-ajax-next-page id=next-page-td_uid_1_5e6a7679e2a1b data-td_block_id=td_uid_1_5e6a7679e2a1b><i class="td-icon-font td-icon-menu-right"></i></a></div><div class=clearfix></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-94118"><a href=https://www.uscho.com/teams/ >Teams</a></li></ul></div></div><div class=td-header-menu-social> <span class=td-social-icon-wrap> <a target=_blank href=https://www.facebook.com/OfficialUSCHO/ title=Facebook> <i class="td-icon-font td-icon-facebook"></i> </a> </span> <span class=td-social-icon-wrap> <a target=_blank href=https://twitter.com/uscho title=Twitter> <i class="td-icon-font td-icon-twitter"></i> </a> </span></div><div class=td-search-wrapper><div id=td-top-search><div class=header-search-wrap><div class="dropdown header-search"> <a id=td-header-search-button-mob href=# class="dropdown-toggle " data-toggle=dropdown><i class=td-icon-search></i></a></div></div></div></div></div></div></div><div class="td-header-header-full td-banner-wrap-full td-container-wrap td_stretch_container td_stretch_content_1400"><div class="td-container-header td-header-row td-header-header"><div class=td-header-sp-recs><div class=td-header-rec-wrap><style>.example_responsive_1{width:320px;height:0px}.custom_ad{width:320px;height:0px}@media(min-width: 500px){.example_responsive_1{width:468px;height:60px}.custom_ad{width:468px;height:60px}#img-ah{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/USCHO_MOBILE_BANNER_AD.jpg")}#img-ch{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/CHA_MOBILE_BANNER_AD.jpg")}#img-new{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/NEWHA_MOBILE_BANNER_AD.jpg")}}@media(min-width: 800px){.example_responsive_1{width:728px;height:90px}.custom_ad{width:728px;height:90px}#img-ah{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/USCHO_Banner_Ad.jpg")}#img-ch{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/CHA_BANNER_AD.jpg")}#img-new{content:url("https://json-cdn.uscho.com/wp-content/uploads/2020/01/NEWHA_BANNER_AD.jpg")}}@media(min-width: 950px){.example_responsive_1{width:970px;height:90px}}@media(min-width: 1050px){.example_responsive_1{width:1020px;height:90px}}</style><div id=ezoic-pub-ad-placeholder-102><ins class="adsbygoogle example_responsive_1" style=display:inline-block data-ad-client=ca-pub-4191647241486880 data-ad-slot=6384904019> </ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div><div class="td-a-rec td-a-rec-id-header  td_uid_2_5e6a7679ecd08_rand td_block_template_1"><style>.td_uid_2_5e6a7679ecd08_rand.td-a-rec-img{text-align:left}.td_uid_2_5e6a7679ecd08_rand.td-a-rec-img
img{margin:0
auto 0 0}</style></div></div></div></div></div></div></div><div class="td-main-content-wrap td-container-wrap"><div class="td-container td-post-template-5 "><div class=td-crumb-container><div class=entry-crumbs><span><a title class=entry-crumb href=https://www.uscho.com/ >Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Picks" class=entry-crumb href=https://www.uscho.com/picks/ >Picks</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class=td-bred-no-url-last>Atlantic Hockey Picks: March 12-15</span></div></div><div class=td-pb-row><div class="td-pb-span8 td-main-content" role=main><div class=td-ss-main-content><article id=post-105106 class="post-105106 post type-post status-publish format-standard has-post-thumbnail hentry category-picks tag-atlantic-hockey tag-frontd1m" itemscope itemtype=https://schema.org/Article><div class=td-post-header><header class=td-post-title><h1 class="entry-title">Atlantic Hockey Picks: March 12-15</h1><div class=td-module-meta-info><div class=td-post-author-name>By <a href=https://www.uscho.com/author/clerch/ title="Posts by Chris Lerch" class="author url fn" rel=author>Chris Lerch</a><div class=td-author-line> -</div></div>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T10:11:42+00:00 >March 12, 2020</time></span></div></header></div><div class=td-post-sharing-top><div id=td_social_sharing_article_top class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class=td-post-sharing-visible><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F"><div class=td-social-but-icon><i class=td-icon-facebook></i></div><div class=td-social-but-text>Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Atlantic+Hockey+Picks%3A+March+12-15&url=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F&via=USCHO"><div class=td-social-but-icon><i class=td-icon-twitter></i></div><div class=td-social-but-text>Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/&amp;media=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg&description=Atlantic+Hockey+Picks%3A+March+12-15"><div class=td-social-but-icon><i class=td-icon-pinterest></i></div><div class=td-social-but-text>Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Atlantic+Hockey+Picks%3A+March+12-15 %0A%0A https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/"><div class=td-social-but-icon><i class=td-icon-whatsapp></i></div><div class=td-social-but-text>WhatsApp</div> </a></div><div class=td-social-sharing-hidden><ul class=td-pulldown-filter-list></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href=# data-block-uid=td_social_sharing_article_top><div class=td-social-but-icon><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-post-content tagdiv-type"><h4>Last Week:</h4><p>Dan: 5-3-0<br> Chris: 7-1-0</p><p>On The Season:<br> Dan: 147-58-23 (.695)<br> Chris: 140-65-23 (.664)</p><p>This Week&#8217;s Picks:</p><p><strong>Thursday, March 12 through Sunday, March 15</strong><br> <strong>Atlantic Hockey Tournament &#8211; Quarterfinals</strong><br> <strong>Best of Three Series</strong></p><div class="td-a-rec td-a-rec-id-content_inlineleft  td-rec-hide-on-tl td-rec-hide-on-tp td-rec-hide-on-p td_uid_3_5e6a7679ef97d_rand td_block_template_1"><style>.td_uid_3_5e6a7679ef97d_rand.td-a-rec-img{text-align:left}.td_uid_3_5e6a7679ef97d_rand.td-a-rec-img
img{margin:0
auto 0 0}</style> <ins class=adsbygoogle style=display:inline-block;width:300px;height:250px data-ad-client=ca-pub-4191647241486880 data-ad-slot=7481584504></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></div><p><strong>Robert Morris at Sacred Heart</strong><br> <strong>Chris:</strong> This series starts on Thursday, with Game Two on Friday and a possible Game Three on Sunday. Robert Morris, which was a goal away from elimination last Saturday, rallied to take its first round series with Holy Cross in three games. I see this one also going three, but with the higher seed coming out on top. <strong>Sacred Heart in three.</strong><br> <strong>Dan: </strong>I don&#8217;t love that RMU has to play the first game on Thursday, just four days after it defeated Holy Cross in the first round, but at the same time, this is the postseason, so I&#8217;m not sure how that will impact them. I think the day off after Thursday will be a big help, and this series will go three. I want to pick SHU here, but RMU in the playoffs is a really bad matchup for anybody. The series will hinge on Saturday. <strong>Sacred Heart in three.</strong></p><p><strong>Bentley at American International</strong><br> <strong>Chris:</strong> Bentley has played some of its best hockey of the season recently and dispatched Canisius to advance out of the first round, but this will be a much higher mountain to climb. Still, I think this series will go the distance. <strong>AIC in three.</strong><br> <strong>Dan: </strong>When AIC left Bentley after its sweep, I felt really good about the Falcons&#8217; future. The second game really rediscovered their mojo and created an atmosphere for a late-season run. This is going to be the series of the weekend, I think, and it&#8217;s going to feature some of the best hockey on the planet. I&#8217;ll call this a proverbial passing of the torch because Bentley will give the Yellow Jackets all they can handle. Next year is 100 percent Bentley&#8217;s year. <strong>AIC in three.</strong></p><p><strong>Air Force at Rochester Institute of Technology </strong><br> <strong>Chris:</strong> These teams played two weeks again, splitting their final regular season series. RIT took three of four games this season, but I like the Falcons to find a way. <strong>Air Force in three.</strong><br> <strong>Dan: </strong>Playing a team that many times in a row is never an advantage for the team with the perceived upper hand, but Air Force hasn&#8217;t been great on the road this year. I&#8217;m going with the Tigers to return to the final four. <strong>RIT sweeps.</strong></p><p><strong>Niagara at Army West Point </strong><br> <strong>Chris:</strong> Both teams earned a bye, so this may come down to which benefited the most from a week off. This one is a tossup in my opinion, but I&#8217;ll go with the higher seed. <strong>Army West Point in three.</strong><br> <strong>Dan: </strong>Niagara has all kinds of momentum after winning its way into a first round bye (with some help from the league&#8217;s new math system). That&#8217;s bad news for Army West POint, which struggled down the stretch and slipped into fourth. I don&#8217;t like this matchup; Niagara was my preseason pick in Atlantic Hockey, so I guess I have to ride that train here. <strong>Niagara in three.</strong></p></div><footer><div class=td-post-source-tags></div><div class=td-post-sharing-bottom><div id=td_social_sharing_article_bottom class="td-post-sharing td-ps-bg td-ps-padding td-post-sharing-style2 "><div class=td-post-sharing-visible><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F"><div class=td-social-but-icon><i class=td-icon-facebook></i></div><div class=td-social-but-text>Facebook</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Atlantic+Hockey+Picks%3A+March+12-15&url=https%3A%2F%2Fwww.uscho.com%2F2020%2F03%2F12%2Fatlantic-hockey-picks-march-12-15%2F&via=USCHO"><div class=td-social-but-icon><i class=td-icon-twitter></i></div><div class=td-social-but-text>Twitter</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/&amp;media=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg&description=Atlantic+Hockey+Picks%3A+March+12-15"><div class=td-social-but-icon><i class=td-icon-pinterest></i></div><div class=td-social-but-text>Pinterest</div> </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Atlantic+Hockey+Picks%3A+March+12-15 %0A%0A https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/"><div class=td-social-but-icon><i class=td-icon-whatsapp></i></div><div class=td-social-but-text>WhatsApp</div> </a></div><div class=td-social-sharing-hidden><ul class=td-pulldown-filter-list></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href=# data-block-uid=td_social_sharing_article_bottom><div class=td-social-but-icon><i class="td-icon-plus td-social-expand-tabs-icon"></i></div> </a></div></div></div><div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class=td-post-next-prev-content><span>Previous article</span><a href=https://www.uscho.com/2020/03/12/this-week-in-big-ten-hockey-in-order-to-beat-ohio-state-michigan-knows-your-top-players-have-to-be-your-top-players/ >This Week in Big Ten Hockey: In order to beat Ohio State, Michigan knows &#8216;your top players have to be your top players&#8217;</a></div></div><div class=td-next-prev-separator></div><div class="td-block-span6 td-post-next-post"><div class=td-post-next-prev-content><span>Next article</span><a href=https://www.uscho.com/2020/03/12/nchc-wcha-cancel-postseason-tournaments-due-to-coronavirus-precautions/ >Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions</a></div></div></div><div class=author-box-wrap><a href=https://www.uscho.com/author/clerch/ ><img alt src='https://secure.gravatar.com/avatar/94c0063537647be940992be3e0a0e99b?s=96&#038;d=mm&#038;r=g' srcset="https://secure.gravatar.com/avatar/94c0063537647be940992be3e0a0e99b?s=192&#038;d=mm&#038;r=g 2x" class='avatar avatar-96 photo' height=96 width=96></a><div class=desc><div class="td-author-name vcard author"><span class=fn><a href=https://www.uscho.com/author/clerch/ >Chris Lerch</a></span></div><div class=td-author-url><a href=http://www.uscho.com/ >http://www.uscho.com/</a></div><div class=td-author-description>Atlantic Hockey Columnist</div><div class=td-author-social></div><div class=clearfix></div></div></div>  <span class=td-page-meta itemprop=author itemscope itemtype=https://schema.org/Person><meta itemprop=name content="Chris Lerch"></span><meta itemprop=datePublished content=2020-03-12T10:11:42+00:00><meta itemprop=dateModified content=2020-03-12T11:23:03-05:00><meta itemscope itemprop=mainEntityOfPage itemType=https://schema.org/WebPage itemid=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/ ><span class=td-page-meta itemprop=publisher itemscope itemtype=https://schema.org/Organization><span class=td-page-meta itemprop=logo itemscope itemtype=https://schema.org/ImageObject><meta itemprop=url content=https://json-cdn.uscho.com/wp-content/uploads/2019/07/uscho150-150x22.png></span><meta itemprop=name content="College Hockey | USCHO.com"></span><meta itemprop="headline " content="Atlantic Hockey Picks: March 12-15"><span class=td-page-meta itemprop=image itemscope itemtype=https://schema.org/ImageObject><meta itemprop=url content=https://json-cdn.uscho.com/wp-content/uploads/2020/02/desbiens.jpg><meta itemprop=width content=700><meta itemprop=height content=466></span></footer></article><div class="td_block_wrap td_block_related_posts td_uid_4_5e6a7679f1ce4_rand td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid=td_uid_4_5e6a7679f1ce4 ><script>var block_td_uid_4_5e6a7679f1ce4=new tdBlock();block_td_uid_4_5e6a7679f1ce4.id="td_uid_4_5e6a7679f1ce4";block_td_uid_4_5e6a7679f1ce4.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_4_5e6a7679f1ce4_rand","td_column_number":3,"live_filter_cur_post_id":105106,"live_filter_cur_post_author":"5","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_4_5e6a7679f1ce4_rand","tdc_css_class_style":"td_uid_4_5e6a7679f1ce4_rand_style"}';block_td_uid_4_5e6a7679f1ce4.td_column_number="3";block_td_uid_4_5e6a7679f1ce4.block_type="td_block_related_posts";block_td_uid_4_5e6a7679f1ce4.post_count="3";block_td_uid_4_5e6a7679f1ce4.found_posts="1406";block_td_uid_4_5e6a7679f1ce4.header_color="";block_td_uid_4_5e6a7679f1ce4.ajax_pagination_infinite_stop="";block_td_uid_4_5e6a7679f1ce4.max_num_pages="469";tdBlocksArray.push(block_td_uid_4_5e6a7679f1ce4);</script><h4 class="td-related-title td-block-title"><a id=td_uid_5_5e6a7679f2b75 class="td-related-left td-cur-simple-item" data-td_filter_value data-td_block_id=td_uid_4_5e6a7679f1ce4 href=#>RELATED ARTICLES</a><a id=td_uid_6_5e6a7679f2b8b class=td-related-right data-td_filter_value=td_related_more_from_author data-td_block_id=td_uid_4_5e6a7679f1ce4 href=#>MORE FROM AUTHOR</a></h4><div id=td_uid_4_5e6a7679f1ce4 class=td_block_inner><div class=td-related-row><div class=td-related-span4><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/07/womens-division-i-college-hockey-conference-semifinal-picks/ rel=bookmark class=td-image-wrap title="Women&#8217;s Division I College Hockey: Conference semifinal picks"><img width=218 height=150 class=entry-thumb src=https://www.photoshelter.com/img-get/I00003ai8dkvATNw/s/700/466/.jpg  srcset="https://www.photoshelter.com/img-get/I00003ai8dkvATNw/s/700/466/.jpg 218w, https://www.photoshelter.com/img-get/I00003ai8dkvATNw/s/700/466/.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Women&#8217;s Division I College Hockey: Conference semifinal picks" title="Women&#8217;s Division I College Hockey: Conference semifinal picks"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/07/womens-division-i-college-hockey-conference-semifinal-picks/ rel=bookmark title="Women&#8217;s Division I College Hockey: Conference semifinal picks">Women&#8217;s Division I College Hockey: Conference semifinal picks</a></h3></div></div></div><div class=td-related-span4><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/07/d-iii-west-conference-championship-game-picks/ rel=bookmark class=td-image-wrap title="D-III West conference championship game picks"><img width=218 height=150 class=entry-thumb src=https://json-cdn.uscho.com/wp-content/uploads/2020/03/ygtx4fr8dh1dz0yp.jpg  srcset="https://json-cdn.uscho.com/wp-content/uploads/2020/03/ygtx4fr8dh1dz0yp.jpg 218w, https://json-cdn.uscho.com/wp-content/uploads/2020/03/ygtx4fr8dh1dz0yp.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="D-III West conference championship game picks" title="D-III West conference championship game picks"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/07/d-iii-west-conference-championship-game-picks/ rel=bookmark title="D-III West conference championship game picks">D-III West conference championship game picks</a></h3></div></div></div><div class=td-related-span4><div class="td_module_related_posts td-animation-stack td_mod_related_posts"><div class=td-module-image><div class=td-module-thumb><a href=https://www.uscho.com/2020/03/06/pickin-the-wcha-quarterfinals-march-6-9/ rel=bookmark class=td-image-wrap title="Pickin&#8217; the WCHA Quarterfinals: March 6-9"><img width=218 height=150 class=entry-thumb src=https://ssl.c.photoshelter.com/img-get/I0000zJEo7h7zHc4/s/700/I0000zJEo7h7zHc4.jpg  srcset="https://ssl.c.photoshelter.com/img-get/I0000zJEo7h7zHc4/s/700/I0000zJEo7h7zHc4.jpg 218w, https://ssl.c.photoshelter.com/img-get/I0000zJEo7h7zHc4/s/700/I0000zJEo7h7zHc4.jpg 436w" sizes="(-webkit-min-device-pixel-ratio: 2) 436px, (min-resolution: 192dpi) 436px, 218px"  alt="Pickin’ the WCHA Quarterfinals: March 6-9" title="Pickin&#8217; the WCHA Quarterfinals: March 6-9"></a></div></div><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/06/pickin-the-wcha-quarterfinals-march-6-9/ rel=bookmark title="Pickin&#8217; the WCHA Quarterfinals: March 6-9">Pickin&#8217; the WCHA Quarterfinals: March 6-9</a></h3></div></div></div></div></div><div class=td-next-prev-wrap><a href=# class="td-ajax-prev-page ajax-page-disabled" id=prev-page-td_uid_4_5e6a7679f1ce4 data-td_block_id=td_uid_4_5e6a7679f1ce4><i class="td-icon-font td-icon-menu-left"></i></a><a href=#  class=td-ajax-next-page id=next-page-td_uid_4_5e6a7679f1ce4 data-td_block_id=td_uid_4_5e6a7679f1ce4><i class="td-icon-font td-icon-menu-right"></i></a></div></div><div id=disqus_thread></div> <script>var embedVars={"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"105106 https:\/\/www.uscho.com\/?p=105106","disqusShortname":"uscho","disqusTitle":"Atlantic Hockey Picks: March 12-15","disqusUrl":"https:\/\/www.uscho.com\/2020\/03\/12\/atlantic-hockey-picks-march-12-15\/","postId":105106};var disqus_url=embedVars.disqusUrl;var disqus_identifier=embedVars.disqusIdentifier;var disqus_container_id='disqus_thread';var disqus_shortname=embedVars.disqusShortname;var disqus_title=embedVars.disqusTitle;var disqus_config_custom=window.disqus_config;var disqus_config=function(){var dsqConfig=embedVars.disqusConfig;this.page.integration=dsqConfig.integration;this.page.remote_auth_s3=dsqConfig.remote_auth_s3;this.page.api_key=dsqConfig.api_key;this.sso=dsqConfig.sso;this.language=dsqConfig.language;if(disqus_config_custom)
disqus_config_custom.call(this);};(function(){var dsq=document.createElement('script');dsq.type='text/javascript';dsq.async=true;dsq.src='https://'+disqus_shortname+'.disqus.com/embed.js';(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(dsq);})();</script> </div></div><div class="td-pb-span4 td-main-sidebar" role=complementary><div class=td-ss-main-sidebar><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id=ezoic-pub-ad-placeholder-104> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4191647241486880 data-ad-slot=7563889977 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></aside><div class="td_block_wrap td_block_9 td_block_widget td_uid_7_5e6a767a0205c_rand td-pb-border-top td_block_template_1 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid=td_uid_7_5e6a767a0205c ><script>var block_td_uid_7_5e6a767a0205c=new tdBlock();block_td_uid_7_5e6a767a0205c.id="td_uid_7_5e6a767a0205c";block_td_uid_7_5e6a767a0205c.atts='{"custom_title":"Latest Stories from around USCHO","custom_url":"","block_template_id":"","header_color":"#","header_text_color":"#","accent_text_color":"#","m8_tl":"","limit":"12","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","csb_visibility":{"action":"show","conditions":{"guest":[],"date":[],"roles":[],"pagetypes":[],"posttypes":[],"membership":[],"membership2":[],"prosite":[],"pt-post":[],"pt-page":[],"pt-guest-author":[],"pt-tdb_templates":[],"tax-category":[],"tax-post_tag":[],"tax-post_format":[],"tax-mens-d-iii":[],"tax-womens-d-iii":[],"tax-other-meta":[],"tax-organizations":[],"tax-awards":[],"tax-defunct":[],"tax-womens-d-i":[],"tax-mens-d-i":[]},"always":true},"csb_clone":{"group":"5","state":"ok"},"class":"td_block_widget td_uid_7_5e6a767a0205c_rand","separator":"","show_modified_date":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"color_preset":"","border_top":"","tdc_css_class":"td_uid_7_5e6a767a0205c_rand","tdc_css_class_style":"td_uid_7_5e6a767a0205c_rand_style"}';block_td_uid_7_5e6a767a0205c.td_column_number="1";block_td_uid_7_5e6a767a0205c.block_type="td_block_9";block_td_uid_7_5e6a767a0205c.post_count="12";block_td_uid_7_5e6a767a0205c.found_posts="24778";block_td_uid_7_5e6a767a0205c.header_color="#";block_td_uid_7_5e6a767a0205c.ajax_pagination_infinite_stop="";block_td_uid_7_5e6a767a0205c.max_num_pages="2065";tdBlocksArray.push(block_td_uid_7_5e6a767a0205c);</script><div class=td-block-title-wrap><h4 class="block-title td-block-title"><span class=td-pulldown-size>Latest Stories from around USCHO</span></h4></div><div id=td_uid_7_5e6a767a0205c class=td_block_inner><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/atlantic-hockey-announces-three-all-conference-teams-one-all-rookie-team/ rel=bookmark title="Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season">Atlantic Hockey announces three All-Conference Teams, one All-Rookie Team for &#8217;19-20 season</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T12:45:11+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/mac-suspends-all-games-march-16-30-in-the-best-interest-of-campus-communities/ rel=bookmark title="MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;">MAC suspends all games March 16-30, &#8216;in the best interest of campus communities&#8217;</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T12:33:37+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/nchc-wcha-cancel-postseason-tournaments-due-to-coronavirus-precautions/ rel=bookmark title="Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions">Five of six men&#8217;s conferences cancel postseason tournaments due to coronavirus precautions</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T12:13:55+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/atlantic-hockey-picks-march-12-15/ rel=bookmark title="Atlantic Hockey Picks: March 12-15">Atlantic Hockey Picks: March 12-15</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/clerch/ title="Posts by Chris Lerch" class="author url fn" rel=author>Chris Lerch</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T10:11:42+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/this-week-in-big-ten-hockey-in-order-to-beat-ohio-state-michigan-knows-your-top-players-have-to-be-your-top-players/ rel=bookmark title="This Week in Big Ten Hockey: In order to beat Ohio State, Michigan knows &#8216;your top players have to be your top players&#8217;">This Week in Big Ten Hockey: In order to beat Ohio State, Michigan knows &#8216;your top players have to be your top players&#8217;</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/drewclaussen/ title="Posts by Drew Claussen" class="author url fn" rel=author>Drew Claussen</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T10:00:52+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/12/this-week-in-nchc-hockey-western-michigan-has-to-keep-winning-to-keep-ncaa-tournament-hopes-alive/ rel=bookmark title="This Week in NCHC Hockey: Western Michigan has to keep winning to have NCAA tournament hopes">This Week in NCHC Hockey: Western Michigan has to keep winning to have NCAA tournament hopes</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/msemisch/ title="Posts by Matthew Semisch" class="author url fn" rel=author>Matthew Semisch</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-12T06:00:05+00:00 >March 12, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/coronavirus-precautions-force-ecac-hockey-to-re-seed-conference-tournament-after-harvard-yale-withdraw/ rel=bookmark title="Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw">Coronavirus precautions force ECAC Hockey to re-seed conference tournament after Harvard, Yale withdraw</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T22:02:34+00:00 >March 11, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/nchc-closes-all-quarterfinal-round-games-to-public-citing-coronavirus-concerns/ rel=bookmark title="NCHC closes all quarterfinal-round games to public, citing coronavirus concerns">NCHC closes all quarterfinal-round games to public, citing coronavirus concerns</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T21:53:15+00:00 >March 11, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/bracketology-as-conference-tournaments-roll-on-teams-looking-to-secure-spots-in-ncaa-tournament/ rel=bookmark title="Bracketology: As conference tournaments roll on, teams looking to secure spots in NCAA tournament">Bracketology: As conference tournaments roll on, teams looking to secure spots in NCAA tournament</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/jimbo15/ title="Posts by Jim Connelly" class="author url fn" rel=author>Jim Connelly</a> and <a href=https://www.uscho.com/author/jayson/ title="Posts by Jayson Moy" class="author url fn" rel=author>Jayson Moy</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T18:00:50+00:00 >March 11, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/minnesota-duluth-foursome-heads-up-2019-20-nchc-all-conference-first-team/ rel=bookmark title="Minnesota Duluth foursome heads up 2019-20 NCHC All-Conference First Team">Minnesota Duluth foursome heads up 2019-20 NCHC All-Conference First Team</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T16:49:19+00:00 >March 11, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/frozen-four-will-be-played-as-planned-but-spectators-not-allowed-due-to-coronavirus-outbreak/ rel=bookmark title="Frozen Four will be played as planned, but spectators not allowed due to coronavirus outbreak">Frozen Four will be played as planned, but spectators not allowed due to coronavirus outbreak</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T16:38:18+00:00 >March 11, 2020</time></span></div></div></div></div><div class=td-block-span12><div class="td_module_8 td_module_wrap"><div class=item-details><h3 class="entry-title td-module-title"><a href=https://www.uscho.com/2020/03/11/harvard-rensselaer-ecac-playoff-series-called-off-ivy-league-cancels-all-spring-athletics-for-remainder-of-season/ rel=bookmark title="Harvard-Rensselaer ECAC playoff series called off, Ivy League cancels all spring athletics for remainder of season">Harvard-Rensselaer ECAC playoff series called off, Ivy League cancels all spring athletics for remainder of season</a></h3><div class=td-module-meta-info> <span class=td-post-author-name><a href=https://www.uscho.com/author/uschostaffreport/ title="Posts by USCHO Staff" class="author url fn" rel=author>USCHO Staff</a> <span>-</span> </span>  <span class=td-post-date><time class="entry-date updated td-module-date" datetime=2020-03-11T14:36:58+00:00 >March 11, 2020</time></span></div></div></div></div></div></div><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div align=center><div id=insticator-container><div id=div-insticator-ad-1></div><div id=insticator-embed embed-id=fafdbd90-5bf0-4794-b385-facb449599dc></div><div id=div-insticator-ad-2></div><script data-cfasync=false type=text/javascript>Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id:"fafdbd90-5bf0-4794-b385-facb449599dc"});</script></div></div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id=ezoic-pub-ad-placeholder-105><ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4191647241486880 data-ad-slot=6979783657 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></aside><aside class="widget_text td_block_template_1 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id=ezoic-pub-ad-placeholder-109> <ins class=adsbygoogle style=display:block data-ad-client=ca-pub-4191647241486880 data-ad-slot=7563889977 data-ad-format=auto data-full-width-responsive=true></ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></aside></div></div></div></div></div><div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-9 td_stretch_container td_stretch_content_1400"><div class=td-container><div class=td-pb-row><div class=td-pb-span12><div class="td-a-rec td-a-rec-id-footer_top  td_uid_8_5e6a767a0908c_rand td_block_template_1"><style>.td_uid_8_5e6a767a0908c_rand.td-a-rec-img{text-align:left}.td_uid_8_5e6a767a0908c_rand.td-a-rec-img
img{margin:0
auto 0 0}</style><div id=ezoic-pub-ad-placeholder-103><style>.example_responsive_1{width:320px;height:100px}@media(min-width: 500px){.example_responsive_1{width:468px;height:60px}}@media(min-width: 800px){.example_responsive_1{width:728px;height:90px}}@media(min-width: 950px){.example_responsive_1{width:970px;height:90px}}@media(min-width: 1050px){.example_responsive_1{width:1020px;height:90px}}@media(min-width: 1200px){.example_responsive_1{width:1200px;height:280px}}</style> <ins class="adsbygoogle example_responsive_1" style=display:inline-block data-ad-client=ca-pub-4191647241486880 data-ad-slot=6384904019> </ins> <script>(adsbygoogle=window.adsbygoogle||[]).push({});</script> </div></div></div></div><div class=td-pb-row><div class=td-pb-span4><aside class="td_block_template_1 widget widget_media_image"><a href=/ ><img width=150 height=22 src=https://json-cdn.uscho.com/wp-content/uploads/2019/07/uscho150.png class="image wp-image-94119 spaced attachment-full size-full" alt style="max-width: 100%; height: auto;"></a></aside></div><div class=td-pb-span4><aside class="td_block_template_1 widget widget_nav_menu"><div class=menu-footer-container><ul id=menu-footer class=menu><li id=menu-item-99467 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-99467"><a href=/about/ >About USCHO</a></li><li id=menu-item-99465 class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-99465"><a href=https://www.uscho.com/contact/ >Contact USCHO</a></li><li id=menu-item-99466 class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-99466"><a href=https://www.uscho.com/jobs/ >Jobs @ USCHO.com</a></li><li id=menu-item-99468 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-99468"><a href=/faq/ >Frequently Asked Questions</a></li><li id=menu-item-99469 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-99469"><a href=/faq/uscho-privacy-policy/ >USCHO Privacy Policy</a></li><li id=menu-item-99470 class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-99470"><a href=/faq/uscho-fan-forum/ >USCHO Fan Forum Policies</a></li></ul></div></aside></div><div class=td-pb-span4></div></div></div></div><div class="td-sub-footer-container td-container-wrap td_stretch_container td_stretch_content_1400"><div class=td-container><div class=td-pb-row><div class="td-pb-span td-sub-footer-menu"><div class=menu-top-header-container><ul id=menu-top-header-1 class=td-subfooter-menu><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-72085"><a href=https://fanforum.uscho.com/ >Fan Forum</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-72084"><a href=https://www.uscho.com/tv/ >TV</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72086"><a href=/podcasts/ >Podcasts</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72087"><a href=/about/ >About USCHO</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-72142"><a href=https://shop.uscho.com/ >shop.USCHO.com</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-80020"><a href=/ncaa/report-a-site-problem/ >Report a site problem</a></li></ul></div></div><div class="td-pb-span td-sub-footer-copy"> &copy;1996-2020 USCHO.com – U.S. College Hockey Online</div></div></div></div></div><style>.special-message-wrapper{background:#C44;color:#FFF;font-size:15px}</style><div class=special-message-wrapper style=display:none;><div class=special-message-content><div class=special-message-left> Please support this website by adding us to your whitelist in your ad blocker. Ads are what helps us bring you premium content! Thank you!</div><div class=special-message-right> <span class="dashicons dashicons-no"></span></div><div style=clear:both;></div></div></div> <script type=text/javascript>jQuery(window).load(function(){if(!document.getElementById("aba_detector")){var aba_cookie=readCookie("Ad_Blocking_Advisor_WP_Plugin")
if(!aba_cookie){jQuery(".special-message-wrapper").show().prependTo(jQuery("body"));}}});jQuery(".special-message-right").click(function(){jQuery(".special-message-wrapper").hide();createCookie("Ad_Blocking_Advisor_WP_Plugin","closed",2);});</script> <style>.gsc-control-cse .gsc-table-result{font-family:inherit}.gsc-control-cse .gsc-input-box{height:inherit}input.gsc-input,.gsc-input-box,.gsc-input-box-hover,.gsc-input-box-focus,.gsc-search-button,input.gsc-search-button-v2{box-sizing:content-box;line-height:normal;margin-top:0px}</style> <style type=text/css media=screen>.td-mobile-content .td-icon-menu-right{display:block}.td_module_8 .entry-title{font-size:14px;line-height:19px}.td-module-comments{display:none}.td_module_8.td_module_wrap{padding:0
0 .5em;margin:0
0 .5em}.td-pulldown-size{font-size: .75em}@media only screen and (min-width: 1000px){.td-pb-span4 .td-ss-main-sidebar{max-width:400px;margin:auto}}.spaced{margin-top:20px}img.teamdir{margin:auto;max-height:25px}td.logobox{display:flex;align-items:center;justify-content:center}.td_module_flex_6{color:white}.sf-menu a.sf-with-ul{padding-right:12px}.tdc-content-wrap{width:100%;padding:0
10px 0 10px}.td-ss-main-sidebar{min-width:300px}.u_datawrapper{width:102%}.threewide{min-width:calc(33% - 5px)}.fourwide{min-width:calc(25% - 5px)}</style><link rel=stylesheet id=lazyload-spinner-css  href='https://cdnjs.cloudflare.com/ajax/libs/jquery.lazyloadxt/1.1.0/jquery.lazyloadxt.spinner.min.css?ver=5.3.2' type=text/css media=all><link rel=stylesheet id=fifu-woo-css-css  href='https://json-cdn.uscho.com/wp-content/plugins/featured-image-from-url/includes/html/css/woo.css?ver=5.3.2' type=text/css media=all><style id=fifu-woo-css-inline-css type=text/css>img.zoomImg{display:inline !important}</style> <script type=text/javascript>var scriptParams={"google_search_engine_id":"010839661138275584990:ohfkrt3zoto"};</script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/ad-blocking-advisor/js/ads.js?ver=1584035449'></script> <script type=text/javascript>var countVars={"disqusShortname":"uscho"};</script> <script type=text/javascript>var wpcf7={"apiSettings":{"root":"https:\/\/www.uscho.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script> <script type=text/javascript src='https://www.google.com/recaptcha/api.js?render=6LdFpLoUAAAAAOPtu0BAg-vCwC6my4jAgNxU4AzM&#038;ver=3.0'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=9.8'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.3'></script> <script type=text/javascript src='https://cdnjs.cloudflare.com/ajax/libs/jquery.lazyloadxt/1.1.0/jquery.lazyloadxt.min.js?ver=5.3.2'></script> <script type=text/javascript src='https://cdnjs.cloudflare.com/ajax/libs/jquery.lazyloadxt/1.1.0/jquery.lazyloadxt.srcset.min.js?ver=5.3.2'></script> <script type=text/javascript>var fifuImageVars={"fifu_lazy":"on","fifu_woo_lbox":"on","fifu_woo_zoom":"inline"};</script> <script type=text/javascript src='https://json-cdn.uscho.com/wp-content/plugins/featured-image-from-url/includes/html/js/image.js?ver=5.3.2'></script> <script type=text/javascript>(function(grecaptcha,sitekey,actions){var wpcf7recaptcha={execute:function(action){grecaptcha.execute(sitekey,{action:action}).then(function(token){var forms=document.getElementsByTagName('form');for(var i=0;i<forms.length;i++){var fields=forms[i].getElementsByTagName('input');for(var j=0;j<fields.length;j++){var field=fields[j];if('g-recaptcha-response'===field.getAttribute('name')){field.setAttribute('value',token);break;}}}});},executeOnHomepage:function(){wpcf7recaptcha.execute(actions['homepage']);},executeOnContactform:function(){wpcf7recaptcha.execute(actions['contactform']);},};grecaptcha.ready(wpcf7recaptcha.executeOnHomepage);document.addEventListener('change',wpcf7recaptcha.executeOnContactform,false);document.addEventListener('wpcf7submit',wpcf7recaptcha.executeOnHomepage,false);})(grecaptcha,'6LdFpLoUAAAAAOPtu0BAg-vCwC6my4jAgNxU4AzM',{"homepage":"homepage","contactform":"contactform"});</script>  <script></script> <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=32', true, [], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=32', false, [], true, false, false, false);
</script>

<script>var _audins_dom="uscho_com",_audins_did=156210;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=188-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.uscho_com,DomainId.156210" border="0" height="1" width="1" alt="Quantcast"/></div></noscript><noscript><img src="https://sb.scorecardresearch.com/p?c1=2&c2=20015427&cv=2.0&cj=1"/></noscript>
<script type='text/javascript' data-cfasync='false'>(function(){function b(g,c){for(var e=0;e<c.length;e++){var d=c[e];if(0==d.complete||"undefined"!=typeof d.readyState&&4>d.readyState){var f=d.getAttribute("src")||d.currentSrc;"undefined"!=typeof d.readyState&&0==d.readyState?d.addEventListener("loadstart",function(h){var k=h.getAttribute("src")||h.currentSrc;window.ezorqs(h,k)}):(f=d.getAttribute("src")||d.currentSrc,window.ezorqs(d,f));d.addEventListener("load",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,
k)});d.addEventListener("loadeddata",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)});d.addEventListener("error",function(h){var k=h.currentTarget.getAttribute("src")||h.srcElement.currentSrc;window.ezorqe(h,k)})}}}function a(g){for(var c=0;c<document.styleSheets.length;c++)if(document.styleSheets[c].href==g)return!0;return!1}b("img",document.querySelectorAll("img"));b("video",document.querySelectorAll("video"));b("audio",document.querySelectorAll("audio"));
(function(g){for(var c=0;c<g.length;c++){var e=g[c];if(("preload"==e.getAttribute("rel")||"stylesheet"==e.getAttribute("rel"))&&null!=e.getAttribute("href")&&a(e.getAttribute("href"))){window.ezorqs(e,e.getAttribute("href"));var d=document.createElement("img");d.onerror=function(f){"undefined"!=typeof f.path&&"undefined"!=typeof f.path[0].currentSrc?window.ezorqe(e,f.path[0].currentSrc):"undefined"!=typeof f.srcElement&&"undefined"!=typeof f.srcElement.href&&window.ezorqe(e,f.srcElement.href)};d.src=
e.getAttribute("href")}}})(document.querySelectorAll("link"));"undefined"!=typeof window.__ez.ssaf&&-1<window.__ez.ssaf.indexOf(16)&&"undefined"!==typeof window.__ez.sshsdef&&!1===window.__ez.sshsdef&&Element.prototype.addEventListener&&("function"==typeof window.onload&&(window.addEventListener("load",window.onload),window.onload=null),"function"==typeof document.onload&&(document.addEventListener.addEventListener("load",document.onload),document.onload=null))})();</script></body></html>